Internet Explorer Enhanced Security Configuration Prevents Usage of Web Applications

Internet Explorer Enhanced Security Configuration Prevents Usage of Web Applications

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Article ID: CTX135627

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Updated On:

Description

The Internet Explorer Enhanced Security Configuration (IE ESC) on the server is disabled for all users (admins and non-admins), but it still shows as enabled when users launch a Published Internet Explorer, and certain Web sites do not work as expected.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Complete the following steps to resolve the issue:
  1. On the affected XenApp server, open the Registry Editor and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap, change the value of “IEHarden” to “0” (zero, disabled).

  2. Recreate the User Profile for all affected users so their profiles reflect the new registry setting on logon.

  3. Restart the server.


Problem Cause

When you disable IE ESC, Windows fails to update a necessary registry key, which causes the update to not reflect for remote users.

Issue/Introduction

This article contains resolution to the issue wherein the Internet Explorer Enhanced Security Configuration prevents usage of Web Applications

Additional Information

CTX128789 - How to Disable Internet Explorer Enhanced Security Configuration on a Windows Server 2008 R2 with XenApp 6