Outlook 2010 Runs Slow in Citrix Virtual Desktop Infrastructure

Outlook 2010 Runs Slow in Citrix Virtual Desktop Infrastructure

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Article ID: CTX135084

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Description

Outlook 2010 is running slow in a Citrix Virtual Desktop Infrastructure.

Resolution

To resolve this issue use online mode so that processing of searches and email can remain on the Exchange server. Microsoft Terminal Services Cached Exchange Mode uses an Offline Folders file with the extension(.ost). This file cannot be used if you have installed Microsoft Terminal Services.


Problem Cause

Verify that Outlook is not running in a "cached mode" but in an "online mode".

Outlook in cached mode in a remote desktop space is not recommended. By using a cached mode, all the processing of search are relegated to the Virtual Desktop Infrastructure (VDI) which does not have the processing power of the Exchange Server, thus presenting a slow response.

In addition, if the Offline Folders (.ost files) of the cached Outlook session is located on a network share, the slowness will be exacerbated.

For these reasons, Outlook is typically configured in online mode when used with VDI. This keeps all mailbox operations and searches on the Exchange server, placing the processing and I/O burden solely on the Exchange environment.

Issue/Introduction

This article contains information about Outlook 2010 running slow in Citrix Virtual Desktop Infrastructure.

Additional Information

Microsoft - Turn on or off Cached Exchange Mode

Microsoft Technet - Limits to using personal folders (.pst) files over LAN and WAN link