Error: "This version of Citrix Receiver does not support selected encryption" When Launching XenApp Application

Error: "This version of Citrix Receiver does not support selected encryption" When Launching XenApp Application

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Article ID: CTX133536

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

Citrix Workspace app is the new universal app for all workspace services, that will encompass all Citrix clients and app capabilities over time.

When launching a Citrix XenApp application after upgrading to a different version of Citrix Receiver, the following error might occur: 
Citrix Receiver Error: "This version of Citrix Receiver does not support selected encryption. Please contact your administrator.

Receiver versions previous to 4.5 can show also the following message: [Error 1046: The Virtual Driver is not loaded.]

However, the applications run without any errors at the second attempt. This issue only occurs when using Citrix Receiver; whereas using earlier versions of ICA client or XenApp Plug-in does not display this error.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

This issue has been resolved. The fix was first introduced with a special release of Receiver 3.4 CU2. This update had also been included with the 4.x version release of Receiver for Windows on June 26, 2013.

There is also a fix for this issue in HDX RealTime Optimization Pack 1.4.200. This update has also been included with 1.5 and all later versions of HDX RealTime Optimization Pack.

Solution 1

Note: If you are still experiencing this error, you may have a corrupt Receiver installation. Try the following steps, if a fresh installation is required:

  1. Download and Run - CTX137494 - Receiver Clean-Up Utility
  2. Verify in Control Panel > Programs and Features or Add/Remove Programs to confirm that the Citrix Receiver software is no longer present.
  3. Restart your computer.
  4. Download and install the latest Citrix Receiver.

Note: If the issue persists, restart your computer and try again.

Solution 2

If solution 1 did not resolve the issue and you are using Receiver 4.2 or newer, then try increasing the timeout by adding the following key:
Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

On 32-bit Windows:
Location: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client
Name: VdLoadUnLoadTimeOut
Type: REG_DWORD
Data: Any value in seconds (Decimal)

On 64-bit Windows:
Location: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Citrix\ICA Client
Name: VdLoadUnLoadTimeOut
Type: REG_DWORD
Data: Any value in seconds (Decimal)

Note: Registry key values are typically listed in decimal format, unless specified otherwise.

Same VdLoadUnloadTimeout registry setting is used in two places with two different default values:

  •          By WfcRun32.exe, when it has seen an error from the engine, and needs to kill the WfIca32.exe process. It waits for this registry setting with a default of 1 second before terminating the process.
  •          By WfIca32.exe, when it is loading virtual drivers.  It waits for this registry setting with a default of 5 seconds for the Virtual driver to load.


If you set the registry setting, then both processes will use the value that you set (in seconds). There is no upper limit.
 
Lower limits are forced. If the value is less than 1 for WfcRun32.exe, it will be forced to 1. If the value is less than 5 for WfIca32.exe, it will be forced to 5.




Solution 3

Misconfigured registry value if there:
If registry key exists set it to default value =True 
Location: HKLM\SOFTWARE\Wow6432Node\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Logon\Local Credentials\
Name: LegacyLocalUserNameAndPassword
Type: REG_SZ
Data: (Default)=True

Note
when we uninstall receiver check if all Citrix related keys under HKLM\SOFTWARE\Wow6432Node\  keys are removed properly.

 


Problem Cause

A call blocked during startup is causing a timeout which results in the error.

Issue/Introduction

This article provides resolution to the error that occurs when launching a Citrix XenApp application after upgrading to a different version of Citrix Receiver.

Additional Information