Citrix Receiver Does Not Respond When Opening Applications to XenApp Servers

Citrix Receiver Does Not Respond When Opening Applications to XenApp Servers

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Article ID: CTX132653

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only. Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.



When opening applications to XenApp servers, there is no response at the Launching… prompt, as shown in the following screen shot:

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Eventually, any of the following errors might appear:

“Attempting to reconnect…”

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Or

“Unable to launch your application…”

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Additional Symptoms

  • The output of a netstat command on both client and server indicate that a valid connection is made on ICA ports 1494 or 2598, as shown in the following screen shot:

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  • Record a network packet trace on the client. The TCP stream indicates the following at the end of the conversation (containing either Vergence or Sentillion as the text):

    VergenceVCCl.ICA......c5...`.......................................................................................................................................................................................
    ................................................VergenceVCCl.ICA......c5...`.......................................................................................................................................
    ................................................................................................VergenceVCCl.ICA......c5...`..............................

  • A CDF trace on the XenApp server might indicate the Vergence or Sentillion driver call:

    INIT_RESPONSE: 2, class 3, bc 256, dll VergenceVCCl

Resolution

To resolve the issue, complete the following steps:

  1. Update the Sentillion/Vergence driver to the latest version.

  2. Change the properties of the module.ini file to read-only in the c:\Program Files\Citrix\ folder. 

Note: This issue is strictly related to the integration of the Microsoft Sentillion or Vergence virtual channel driver into the Citrix ICA client by using module.ini. If the problem persists, it is recommended to report the issue to Microsoft for further investigation.


Problem Cause

The cause of the issue is an incorrect module.ini file in the c:\Program Files\Citrix\ folder that is modified by the Sentillion/Vergence SSO product.

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Issue/Introduction

This article contains the resolution when the Citrix Receiver does not respond when opening applications to XenApp Servers.

Additional Information

Microsoft Sentillion or Vergence uses these settings in the module.ini file to load a virtual channel to facilitate SSO into a hosted published application on a XenApp server.