Error: "You cannot add apps at this time" on Receiver StoreFront

Error: "You cannot add apps at this time" on Receiver StoreFront

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Article ID: CTX132221

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

Domain users receive the following error after logging in using Receiver for Website :

“You cannot add apps at this time”

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Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

Solution 1

Ensure you enter the correct Fully Qualified Domain Name (FQDN) to the XML server(s). If the DNS service is disabled in the network and you still require FQDN; alternatively, you can use host entries inside the Windows hosts file.

Solution 2

Complete the following steps to fix the issue:

  1. Assign the correct XML port number to the XML server(s) under Manage Server Farms in StoreFront Services console.

  2. Ensure the Citrix XML service is running on the XML server(s).

  3. Ensure the Citrix IMA service is running on the XML server(s).

Solution 3

Ensure that the root Certificate Authority (CA) certificate is installed correctly on StoreFront Services server to establish a successful SSL connection to the backend XML server(s). Import the root CA to trust the XML server(s) in the certificate store under Local Computer > Trusted Root Certification Authorities > Certificates.

Example of Importing a root CA certificate

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Solution 4

Ensure that the XML traffic is not being blocked by a firewall or any other third-party solution monitoring the network traffic.


Problem Cause

Cause 1

StoreFront server is unable to resolve the name of the XML server(s) listed under Manage Server Farms.

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The following error message is recorded on StoreFront server under Event Viewer > Applications and Security logs > Citrix Delivery Services:

Log Name: Citrix Delivery Services
Source: WebApplication
Date: <Date>
Event ID: 0
Task Category: (12346)
Level: Error
Keywords: Classic
User: N/A
Computer: ftlvstorefront.amc.ctx
Description:

The server name ftlvxa.amc.ctx cannot be resolved. The specified Citrix XML Service could not be contacted and has been temporarily removed from the list of active services.

Cause 2

StoreFront server is unable to contact the XML server(s) using the specified XML port number under Manage Server Farms.

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The following error message is recorded on StoreFront server under Event Viewer > Applications and Security logs > Citrix Delivery Services:

Log Name: Citrix Delivery Services
Source: WebApplication
Date: <Date>
Event ID: 0
Task Category: (12346)
Level: Error
Keywords: Classic
User: N/A
Computer: ftlvstorefront.amc.ctx
Description:

An error occurred while attempting to connect to the server ftlvxa45.amc.ctx on port 81. Verify that the Citrix XML Service is running and is using the correct port. If the XML Service is configured to share ports with Microsoft Internet Information Services (IIS), verify that IIS is running. This message was reported from the XML Service at address. The specified Citrix XML Service could not be contacted and has been temporarily removed from the list of active services.

Cause 3

If using HTTPS or SSL Relay as the transport type, StoreFront Services server is unable to contact the XML server(s) using Secure Socket Layer (SSL).

Example of SSL Relay configuration

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The following error message is recorded on StoreFront server under Event Viewer > Applications and Security logs > Citrix Delivery Services:

Log Name: Citrix Delivery Services
Source: WebApplication
Date: <Date>
Event ID: 0
Task Category: (12346)
Level: Error
Keywords: Classic
User: N/A
Computer: ftlvstorefront.amc.ctx
Description:

An SSL connection could not be established: You have not chosen to trust the issuer of the server's security certificate, amc-FTLVAMCDC-CA. This message was reported from the Citrix XML Service at address. The specified Citrix XML Service could not be contacted and has been temporarily removed from the list of active services.

Cause 4

Third-party network monitoring solutions (for example: firewalls, Intrusion Detection Systems (IDS), antivirus) might be blocking the XML traffic between StoreFront Services and the XML server(s).

Issue/Introduction

This article explains how to fix StoreFront Services server communication issues against XML server(s) listed under Manage Server Farms in a Store.