XenApp Error When Session Printing Policy is Added

XenApp Error When Session Printing Policy is Added

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Article ID: CTX132164

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Updated On:

Description

When a Session Printing policy is added, one of the following errors appear:

“Could not query the printer information for printer \\<PrintServerName>\<PrinterName>”

or

“The Operation could not be completed (error 0x00000bc4). No printers were found"

However, the following can be performed:
  • Run the ping <PrinterName> command successfully

  • Connect through Internet Explorer to the IP address of the <PrintServer>

  • Run \\PrintServer\<PrinterName> from a Command Prompt Window

  • Connect to \\PrintServerIP>\<PrinterName>

Adding the <PrintServerIP> <PrintServerName> to the Host file does not resolve the issue.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

To resolve this issue, complete the following steps:

  1. Open registry on your computer.

  2. Open the HKEY_LOCAL_MACHINE\Software\Microsoft Windows NT\CurrentVersion\Print\Providers\Client Side Rendering\Servers folder.

  3. Export the key.

  4. Delete the <PrintServerName> key under the Servers key and restart the computer.


Problem Cause

This error may occur if information under HKEY_LOCAL_MACHINE\Software\Microsoft Windows NT\CurrentVersion\Print\Providers\Client Side Rendering\Servers key is corrupt.

Issue/Introduction

When you add a Session Printing policy you receive one of the following errors: “Could not query the printer information for printer \\\” or “The Operation could not be completed (error 0x00000bc4). No printers were found".

Additional Information

http://support.microsoft.com/default.aspx?scid=kb;EN-US;954367

http://support.microsoft.com/default.aspx?scid=kb;EN-US;2546625

http://support.microsoft.com/kb/947236