Google Chrome Becomes Unresponsive when Started as Published Application

Google Chrome Becomes Unresponsive when Started as Published Application

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Article ID: CTX132057

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Updated On:

Description

When users try to start a published Google Chrome browser, the browser starts but eventually becomes unresponsive displaying a blank page. If the user tries to open Google Chrome inside a published desktop, the browser opens with no problems. With the new versions of the Google Chrome browser, the following error message is displayed. Besides this error, some users get a gray screen with no message depending on the current version testing.
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Resolution

Solution 1

Complete the following steps to troubleshoot this issue:

  1. Ensure Google Chrome v.24 or later version is being used. This version has a couple of fixes regarding the usage in terminal service environment Citrix or Microsoft.

  2. Open Properties from the published application settings of Google Chrome on the Delivery Service Console or Citrix AppCenter Console.

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  3. Select Location under Properties and add the parameter --allow-no-sandbox-job --disable-gpu in the Command line.

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  4. Click OK to save the settings.
    Refresh the application on the client workstation and open the browser.

Note: The administrator can publish the Google Chrome application and it works fine for non-flash based websites. If the user browses to a flash based website, the Chrome browser flash plugin crashes. In order to avoid this issue follow the instructions on Disable PepperFlash in Chrome. Additional information can also be found in the Google Product Forums - How to permanently disable Pepper Flash on Chrome?

Solution 2

if you are using Google Chrome Enterprise 32 bit, it does not require any switches.


Problem Cause

This issue is not regarding Citrix XenApp. The same error and behavior occurs if the user starts the Google Chrome browser through Microsoft RemoteApp technology. The application starts but the same error appears, however when starting a Remote Desktop application, it starts without any error. The issue occurs with Windows 7, Windows Server 2008, and Windows Server 2008 R2.

Issue/Introduction

This article provides procedure to resolve Google Chrome error when users try to start a published Google Chrome browser and the browser becomes unresponsive.

Additional Information

CTX131935 - How to Create a Streaming Profile for Google Chrome Browser
Google Product Forums - How to permanently disable Pepper Flash on Chrome?
(Third Party Site) - Disable PepperFlash in Chrome