Pass-Through Authentication Malfunctions when Using Receiver for Windows

Pass-Through Authentication Malfunctions when Using Receiver for Windows

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Article ID: CTX131858

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Updated On:

Description

Pass-through Authentication malfunctions when using Citrix Receiver for Windows.

Background

When trying to start applications from a XenApp services site using Citrix Receiver for Windows, after entering the username and the password, a prompt appears to re-authenticate against the server hosting the application. This issue continues to occur even if the XenApp environment is correctly configured with pass-through authentication

More information about troubleshooting pass-through authentication is available in the Knowledge Center article CTX368624 - Troubleshooting Citrix Pass Through Authentication.

Resolution

Specify the correct domain name in combination with the username when logging on to Citrix Receiver for Windows, as displayed in the following screen shot:

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Problem Cause

One of the reasons for this issue to occur is when there is no domain specified when logging into Citrix Receiver for Windows.

Even though the Citrix Receiver allows you to log on and subsequently enumerates applications without specifying a domain name, the credentials when passed to XenApp server are interpreted as an attempt to logon to the server locally, since there was no domain name specified. This scenario is explained in the following procedure:
  1. Logging on to Citrix Receiver for Windows.

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  1.  After attempting to start the application, a prompt to re-enter the user credentials appears.

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  1. The server rejects the credentials because there was no domain specified:

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  1. After choosing the option to switch user accounts and the domain name is specified, the application starts successfully.

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Issue/Introduction

Pass-Through Authentication Malfunctions Using Receiver for Windows

Additional Information

CTX368624 - Troubleshooting Citrix Pass Through Authentication