Application Launch Fails with Protocol Driver Error after Changing the Static IP Address of the XenApp Server

Application Launch Fails with Protocol Driver Error after Changing the Static IP Address of the XenApp Server

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Article ID: CTX131831

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Updated On:

Description

When attempting to launch an application after changing the static IP address of the XenApp server hosting the application, the following error message appears:
“Unable to launch your application. Contact your help desk with the following information: Cannot connect to the Citrix XenApp server. Protocol Driver Error”

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Resolution

To resolve the issue, complete the following procedure:
  1. Stop the Citrix XTE Server service.

  2. Locate the httpd.conf file on the server.

    • For 64-bit version of Windows Sever the file can be located by navigating to the “Program Files (x86)\Citrix\XTE\conf” folder.

    • For 32-bit version of Windows Server the file can be located by navigating to the “Program Files\Citrix\XTE\conf” folder.

  3. Open the file, httpd.conf, by using a simple text editor, such as Notepad.

  4. Locate any instance of an old IP address of the server and modify it to reflect the new IP address.

  5. Save the changes.

  6. Start the Citrix XTE Server service.


Problem Cause

When changing the static IP address of a server the applications fail to launch. One of the causes for this issue is that the httpd.conf file on the XenApp server is not updated with the new IP address of the server. The httpd.conf file is used by the Citrix XTE Server service for Session Reliability. If this file does not contain the correct information, applications fail to launch.

Issue/Introduction

This article provides resolution to fix the failure of application launch with the Protocol Driver error that occurs when the Static IP address of the XenApp server is changed.

Additional Information

CTX114680 – Event Log Error: An error occurred when processing incoming CGP downstream data