Error: You cannot access this session because no licenses are available - Citrix Virtual Desktops

Error: You cannot access this session because no licenses are available - Citrix Virtual Desktops

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Article ID: CTX130961

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Description

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  • A Citrix Virtual Desktops session fails to start with the following error: "You cannot access this session because no licenses are available." Event ID: 9027, Event ID: 1163
  • Event Source: Citrix ICA Service
  • Error 0 received while obtaining a license for a Citrix XenApp client connection.
  • The license request has been rejected.
    • Note: The license error “flex code -18” shown in the DDC log stands for “License server system does not support this feature”.
  • The Broker log might contain the following errors:
    • Controller:EventLogManager decided to log event CDS_EVENT_LICENSE_NONE_CHECKED_OUT of type Warning with arguments:
      • This is based on event log groups LicensingCheckout
    • Licensing:MFLic_GetLicense result Success, request result Rejected
    • Licensing:License request rejected, flex code -18

Resolution

 

Resolution 1 - Event ID: 9027

  1. Check the configuration of the site: Citrix Virtual Desktops License edition and model using PowerShell command "Get-BrokerSite"  which shows license configuration for the site.
For Virtual Machine hosted applications
  • AppLicenseEdition
  • ApplicationLicenseModel
For Citrix Virtual Desktops​ sessions
  • DesktopLicenseEdition
  • DesktopLicenseModel
  1. Compare the configuration with the licenses used in the environment from license server.  Check the licenses in the license server.  Change the site configuration using the Set-BrokerSite PowerShell command.

Examples

To configure the site to use the Premium edition (formerly platinum), use the following command:
  • Set-BrokerSite -DesktopLicenseEdition PLT
To set up Virtual Machine hosted applications to use Premium edition:
  • Set-BrokerSite -AppLicenseEdition PLT
 

Resolution 2:

  1. Download and install the most recent version of the licensing server.
  2. On the DDC, restart the Citrix services:​ (This can be done on a live system and will not affect the users)
    • Citrix AD Identity Service
    • Citrix Broker Service
    • Citrix Configuration Service
    • Citrix Diagnostic Facility COM Service
    • Citrix Host Service
    • Citrix Machine Creation Service
    • Citrix Machine Identity Service
  3. On the License Server, restart Citrix services.
    • Citrix Licensing
    • Citrix Licensing Config Service
    • Citrix Licensing Support Service
  4. Access Desktop Studio > Configuration > Licensing > Change Licensing Server > Verify.
  5. If the issue persists, restart all the DDCs in the farm one by one.

     

    Resolution 3 - Event ID: 1163

    1. In this case, upgrade the database as prompted by Citrix Virtual Desktops Studio.
    User-added image
     
    1. Restart the Desktop Studio Server, error should no longer appear.


    Resolution 4

    1. Confirm all licenses are visible in License admin console.
    2. Verify maintenance end date of licenses are relevant to version of product.
    3. Confirm start up server is showing in License admin console and hosts are communicating.
    4. Import startup.lic or reinstall license admin console, which should create a new startup.lic.
    • ​Issue occurs mainly due to either corrupt startup.lic or no startup.lic under C:\Program Files\Citrix\Licensing\MyFiles
    1. Restart Citrix licensing service.
    2. Relaunch application, error should no longer appear.
     
     

      Problem Cause

       
      • Event ID: 9027 Licensing is not set up properly in XenDesktop Site; licenses are not checked out on the license server when the user tries to start a new Citrix Virtual Desktops session.
      • License Model: Could be User/Device or Concurrent License Edition: Could be Premium, Advanced (ADV), or Standard  edition.
      • Event ID: 1163 Citrix Virtual Desktops Upgrade did not complete successfully and the following error was observed in the Citrix Virtual Desktops Studio: “A database upgrade is available. Learn more about this upgrade”
      • Startup license file is missing from the My Files folder.
      • corrupt startup.lic or no startup.lic under C:\Program Files\Citrix\Licensing\MyFiles

      Issue/Introduction

      This article describes the methods to overcome the error "You cannot access this session because no licenses are available" when launching a Citrix Virtual Desktops session. XenDesktop has been re-branded to Citrix Virtual Desktops.

      Additional Information

      Error: You Cannot Access this Session Because no License are Available. Event ID 1163