Error: The User Profile Service service failed the logon. User profile cannot be loaded

Error: The User Profile Service service failed the logon. User profile cannot be loaded

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Article ID: CTX130776

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Updated On:

Description

When attempting to change the Personal vDisk drive letter from the default V: drive to an alternative such as U:, the user profile service displays the following error when the users attempt to log on to the desktop:

“The User Profile Service service failed the logon.

User profile cannot be loaded.”

User-added image

Environment

  • Configured XenDesktop 5.5 deployment

  • Citrix Personal vDisk 5.5.0

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Complete the workaround as per your requirement.

Workaround

Option 1

Note: This workaround does not require deletion of the existing virtual machines.

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Log on to the previously failed virtual machines as administrator.

  2. Navigate to the registry location.

  3. Change the drive letter value from V:\Users to U:\Users for the ProfilesDirectory key, which can be found at HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\

Alternatively push the registry change using Microsoft Group Policy. Refer to Microsoft documentation for details.

Tip: After building the virtual machine golden master image and installing the Citrix Personal vDisk software, perform the change of drive letter in the first instance before shutting down the virtual machine.

Option 2

Note: Recreate the machines for this workaround.

To delete the existing virtual machines in Desktop Studio and deploy new virtual machines after the Base virtual machine is updated as Option 1.

Complete the following procedure for Option 2:

  1. On the virtual machine golden master, install Citrix Personal vDisk 5.5.0 software.

  2. Right-click and select Preferences from the Citrix Personal vDisk icon in the systray,

  3. Change the drive letter from V: to U:.

  4. Click OK and close the tool.

  5. Shut down the virtual machine.

  6. Update the Inventory when prompted.

  7. Take a snapshot and update the Machine Catalogue for the Desktop Group using the new snapshot.

Solution 3

Install MS hotfixes KB2775511,
https://support.microsoft.com/en-us/kb/2871131 
Compress hive (HKEY_USERS\.DEFAULT\Printers\DevModePerUser & DevModes2) .
https://support.microsoft.com/en-us/kb/2498915


Problem Cause

The drive letter change is discarded by user mode component when base image is changed, but not by kernel mode component.

Issue/Introduction

This article provides a resolution to the following error: "The User Profile Service service failed the logon. User profile cannot be loaded."

Additional Information

For more information, refer to the XenDesktop documentation and Citrix Personal vDisk 5.5.0 documentation.