When attempting to create a Catalog using Machine Creation Services (MCS), the wizard ends with the following error:
The Catalog could not be loaded due to the following errors: There are no master images associated with this catalog
Follow the solution corresponding to the cause to resolve the issue:
CAUSE 1
Incorrect configuration of the Hard Disk for the master VM. The Citrix Desktop wizard shows the size as 0 GB.
The incorrect value was traced to an improper configuration of the storage for the master VM in XenServer:
The device position for the local storage shows as 1 when it should be 0.
SOLUTION 1
In the same Storage tab, select Detach to temporarily remove the hard disk, and then select Attach to recreate the connection.
CAUSE 2
A change in the networking configuration of the Citrix Delivery Controller (DDC) took place, which caused the connection to the hypervisor to stop functioning correctly. For example, the IP address or the default gateway address was changed on the network adapter of the DDC.
SOLUTION 2
In the DDC, open the Desktop Studio console and expand the Configuration node.
Select the Hosts node and wait until the configured hosts are listed in the middle pane of the console.
Right-click the configured host and select Change details.
In the dialog box that opens, verify that address and user are correct for the hypervisor, and re-enter the password.
Click OK.
Open the Hosts node in the DDC console.
Select Add Host and define a new connection.
Run the Create Catalog wizard again, this time selecting only the new host just created.
This should resolve the problem.
CAUSE 3
There has been a change in the Storage location of the Host connection in Citrix Studio that the Machine Catalog is pointed to.
SOLUTION 3
Point the existing host connection to the proper storage location. If you have recently replaced the SAN, point the existing host connection to the new SAN.CTX127594 - XenDesktop 5.0 Quick Start Guide
CTX128328 - FAQ: XenDesktop 5.x