Error: Windows cannot connect to the printer. Operation could not be completed (Error 0x00000006)

Error: Windows cannot connect to the printer. Operation could not be completed (Error 0x00000006)

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Article ID: CTX129315

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Updated On:

Description

When a printer is connected from the cluster, the following error appears:

"Windows cannot connect to the printer. Operation could not be completed (Error 0x00000006)"

There is no issue to connect to printers in the cluster from a physical client but the problem is from the "Printcluster is Win2008 x86" virtual Windows 7 Virtual Desktop Infrastructure client in XenDesktop.

Clustername: Printcluster
Clusternode1: Print01
Clusternode2: Print02

Connect local printer on print01 = Works (\\print01\printer01)
Connect local printer on print02 = Works (\\print02\printer01)
Connect printer from clustername = Not Working (\\printcluster\printer01)

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve the issue, complete the following steps:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Delete the following Registry key:

    HKLM\Software\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers\

  2. Restart the Virtual Desktop Infrastructure client.

  3. Test the connection.


Problem Cause

This issue occurs because the Client Side Rendering Print Provider registry entry is corrupted.

Issue/Introduction

This article provides a resolution for the error "Windows cannot connect to the printer. Operation could not be completed (Error 0x00000006)".