IMA Service Fails with Events: 3989, 3634, 3614

IMA Service Fails with Events: 3989, 3634, 3614

book

Article ID: CTX128971

calendar_today

Updated On:

Description

When restarting the Desktop Delivery Controller 4.0 server, the IMA Service fails and logs the following events:

  • eventid 3989: "The Citrix Presentation Server failed to connect to the Data Store. ODBC error while connecting to the database: 08001 -> [Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.”

  • eventid 3634: "The server running Citrix Presentation Server failed to connect to the data store. The database is down or there is a network failure. Error: IMA_RESULT_DBCONNECT_FAILURE  Indirect: 0  Server:   DSN file: D:\Citrix\Independent Management Architecture\MF20.dsn"

  • eventid: 3614: The server running Citrix Presentation Server failed to connect to the Data Store.  Error - IMA_RESULT_DBCONNECT_FAILURE The database is down or there is a network failure.

Citrix Desktop Delivery Controller Service, Citrix IMA Proxy Service, and Citrix Pool Management Service are also failing to start, as the IMA Service is unresponsive during the startup.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

To resolve the issue, add network account permission to the following key:

HKLM\SOFTWARE\Microsoft\MSSQLServer\Client\SuperSocketNetLib\LastConnect

Workaround

As a workaround, grant NETWORK Service administrator rights or change the IMA service to run in SYSTEM context.


Problem Cause

The issue occurs because of security rights.

Note: When you create an NT AUTHORITY\Network Service account, which is the security context, the IMA service runs in a member of the local administrator group on the server (or if the service is changed to run under a SYSTEM account), all services start as expected.

Issue/Introduction

The article provides a resolution for an issue with IMA Service that fails with the events: 3989, 3634, 3614.