Keyboard Layout Does Not Match iPad or iPod Language

Keyboard Layout Does Not Match iPad or iPod Language

book

Article ID: CTX128347

calendar_today

Updated On:

Description

When launching a published application from an iPad or iPod, the default language inside of the ICA session does not match the default language of the iPad or iPod.

Resolution

Configure the server default language to the language that the mobile users need. To verify what the server default language is currently set to, check the following registry value:
\HKEY_USERS\.DEFAULT\Keyboard Layout\Preload\1

If the value is set to 000000409, then the default is set to English.
The following list shows all available values (use the LCID Hex values): Locale IDs Assigned by Microsoft.

Note: The Input Language settings has to match the Default Language settings. This needs to be changed manually.


Problem Cause

The receiver does not have the ability to change the Server Language based on the client’s language. Instead, it uses the server's default keyboard language settings.

Issue/Introduction

When launching a published application from an iPad or iPod, the default language inside of the ICA session does not match the default language of the iPad or iPod. This article article explains how to correct this issue.