Windows 2008 R2 Server Becomes Unresponsive, Preventing RDP and ICA Connections, Requiring a Reboot

Windows 2008 R2 Server Becomes Unresponsive, Preventing RDP and ICA Connections, Requiring a Reboot

book

Article ID: CTX128322

calendar_today

Updated On:

Description

Under certain circumstances a Windows Server 2008 R2 based server running XenApp 6.x becomes unresponsive.

After users disconnect or end their session, all current user sessions stop responding and no new Remote Desktop Protocol (RDP) or Independent Computing Architecture (ICA) sessions can be started to the server. If the server is rebooted, this behaviour is resolved for an unspecified time, but the issue might reoccur.

Resolution

Microsoft Support has identified this issue and has released the following hotfix:
http://support.microsoft.com/kb/2465772

Note: This issue is for Windows Server 2008 R2 only; it does not affect earlier platforms.


Problem Cause

Based on the investigation performed by Citrix and Microsoft Technical Support, under certain circumstances a condition occurs between simultaneous TCP session connects and disconnects.

Issue/Introduction

This article provides resolution when under certain circumstances a Windows Server 2008 R2 based server running XenApp 6.x becomes unresponsive.