Published Application Fails to Launch Outside of Desktop Session
book
Article ID: CTX127874
calendar_today
Updated On:
Description
A published application does not start properly. The same application starts in a published desktop session for the same user. This affects user profiles when the profile on the Terminal Server (TS) is created by launching a published application. However, if the first time launch (when the user profile is created) is based on a published desktop session, no problems occur even if you launch the application as a published application thereafter.

Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Workarounds
Complete the following steps as a workaround for the issue:
-
Create the user profile by first launching a full desktop session.
-
Start the runonce.exe file together with the /AlternateShellStartup switch.

-
In the server Group Policy Management Console, navigate to Local Computer Policy > User Configuration > Windows Settings.
-
Click Scripts (Logon/Logoff), and then double-click Logon.
-
Click Add.
-
In the Script name box, type runonce.exe.
-
In the Script parameters box, type /AlternateShellStartup.
-
Click OK two times.
Alternate Approach
Another approach is to narrow down which exact run key needs to be executed to solve the profiling issue.
Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.
- Isolate the process by removing the values from the run key.
- Delete the profile and launch a published desktop session, then remove another value, delete the profile and launch a desktop session.
- Repeat the process until the application does not start even in published desktop mode.
- Once the required process is isolated, put back everything into the run key and modify the login script to execute only the one needed process instead of the runonce command.

Problem Cause
If
wfshell is not loaded, the default.profile is not created correctly. This behavior occurs because when the explorer shell is not loaded with the Run registry entry, the RunOnce registry entry and the startup applications are not loaded. If you start a published application which depends on wfshell, it might fail to load because of dependencies executed in the
runonce command.
Issue/Introduction
This article provides resolution when the Published Application does not launch for user.
Additional Information
The issue is a design problem by Microsoft. Hence, no solution can be provided by Citrix. However, you can refer to the workarounds.
Also, refer
http://support.microsoft.com/kb/951048
Was this article helpful?
thumb_up
Yes
thumb_down
No