NetScaler EPA Scan for Antivirus Fails on a 64-bit Client Computer

NetScaler EPA Scan for Antivirus Fails on a 64-bit Client Computer

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Article ID: CTX127807

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Updated On:

Description

The NetScaler End Point Analysis (EPA) scans for antivirus software fail on 64-bit client computers.

The EPA scans fail with security error on 64-bit Windows 7 client computers when antivirus security expressions are configured. This error does not allow a Virtual Private Network (VPN) user to log in and establish a VPN session.

Resolution

To resolve this issue, add a _64 suffix to the registry value in the expression as mentioned in the following sample expression:
CLIENT.REG('HKEY_LOCAL_MACHINE_64\\\\SOFTWARE\\\\McAfee\\\\\AVEngine_AVDatVersion').VALUE == 6198 -frequency 5

Using the _64 suffix to the registry value in the expression ensures that the scan checks the regular as well as the 64-bit registry.


Problem Cause

For an application on a 32-bit computer, there is only one registry to access. However, a 64-bit computer has two registries, the regular registry and 64-bit registry. The EPA needs to access an appropriate registry for the scan to be successful.

Issue/Introduction

The NetScaler End Point Analysis (EPA) scans for antivirus software fail on 64-bit client computers.