"ERROR: Private Key for the certificate-key pair is not present" is Displayed when Binding a Certificate in NetScaler Appliance
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Article ID: CTX126403
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Updated On:
Description
After installing a certificate on a NetScaler appliance, when binding the certificate to a virtual server, the following error message is displayed:

Resolution
To resolve this issue, remove the certificate and reinstall it on the appliance. Ensure that you specify the certificate and private key files in the Certificate File Name and Private Key File Name fields respectively, as shown in the following screen shot:

Note: If the certificate is a .PFX file that contains the certificate as well as private key, convert the certificate format from .PFX to .PEM. Ensure that you specify the same file name in the
Certificate File Name and
Private Key File Name fields, as shown in the following screen shot:

Problem Cause
When installing the certificate on a NetScaler appliance, a private key might not been specified as shown in the following screen shot:

Issue/Introduction
After installing a certificate on a NetScaler appliance, when binding the certificate to a virtual server (VServer), the error message "Binding CertKeys:Certificate is not a server certificate" is displayed.
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