NetScaler Displays Multiple Error Messages when Installing Microsoft SharePoint AppExpert Template using Wizard

NetScaler Displays Multiple Error Messages when Installing Microsoft SharePoint AppExpert Template using Wizard

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Article ID: CTX126154

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Updated On:

Description

When the Microsoft SharePoint AppExpert template is installed through the AppExpert Template Wizard, the NetScaler  displays multiple error messages, as shown in the following screen shots:

  • Error creating resource Sharepoint_inval1: No such resource
    User-added image

  • Error creating resource Sharepoint_inval1_s1: No such resource
    User-added image

  • Error binding cache policy inval_sharepoint_document to policy label  Sharepoint_cache_s1
    No such policy exists

    User-added image

  • Error binding cache policy inval_sharepoint_fp_dld_docs to policy label Sharepoint_cache_s1
    No such policy exists
    User-added image

Resolution

When the Microsoft SharePoint AppExpert template is deployed, ensure that the NetScaler is licensed for the following features, which are required for Microsoft SharePoint:

  • Compression
  • Integrated Caching
  • Load Balancing
  • SSL Offloading
  • Content Switching
If Integrated Caching license is not enabled, edit Microsoft SharePoint AppExpert template file to delete Integrated Caching related policies and the bindings of the policies. Now the Microsoft SharePoint AppExpert template should be imported without any error. However, for best performance, it is recommend to use Integrated Caching in SharePoint deployments.

Problem Cause

The errors occur when a user attempts to install the Microsoft SharePoint AppExpert template on a NetScaler that has a Standard Edition license installed on it. The NetScaler with Standard Edition license installed on it does not include Compression and Integrated Caching features.
For detailed information about NetScaler licensing refer to the following link:
http://docs.citrix.com/en-us/netscaler/11/license-upgrade-downgrade/netscaler-licensing-overview.html
http://support.citrix.com/article/CTX121062
 

Issue/Introduction

This article provides a resolution to multiple errors that occur in NetScaler when installing Microsoft SharePoint AppExpert template using AppExpert template wizard.

Additional Information

SharePoint Drop-Down Menu Options Not Working When Connecting Through NetScaler
Cannot Edit/Open Office Documents in SharePoint Unless SharePoint is in Trusted Sites in Internet Explore​
Some SharePoint Options are Disabled When Accessed Through NetScaler​
Product Documentation: AppExpert Applications and Templates​ on NetScaler