XenApp 6 QFarm/load of 20000 and Policy Information is Removed from the Registry

XenApp 6 QFarm/load of 20000 and Policy Information is Removed from the Registry

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Article ID: CTX125363

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Updated On:

Description

The XenApp 6/6.5 server is unable to contact the license server after a reboot. The output of the Qfarm /load command indicates a server load of 20000.

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Changing the license server name under policies to a false name and then changing back to the correct name (gpupdate /force and an IMA service restart might be needed) resolves the issue until the server is rebooted.

Citrix Policies created using the Delivery Services Console might not be applied.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

As a permanent solution, install the following hotfix:

CTX126324 – LIMITED RELEASE - Hotfix XA600W2K8R2X64009 - For Citrix XenApp 6.0 for Windows Server 2008 R2 - English

“Restarting the IMA Service while the data store is unavailable results in the temporary deletion of certain farm policy settings from the server. This occurs because reading the settings from the local host cache - intended as a backup mechanism for retrieving farm policy settings in case the data store is down - does not work properly.

Even without this fix, the issue is temporary: restarting the IMA Service as soon as the data store is available again repopulates the farm policy settings. This fix addresses the issue that prevents the proper reading of the farm policy settings from the local host cache in the first place.”

 - From [XA600W2K8R2X64009][#234694]

Workarounds

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

If the Citrix Licensing information (ServerName and Port) was added during the Farm creation and when subsequent servers were joined to the farm, investigate the following:
  1. Use dsview.exe from the Support\Debug folder within the XenApp 6/6.5 server media.
  2. Expand Server Neighborhoods > TheNameoftheFarm > MFServerFarm > Parameters and Server Neighborhoods > TheNameoftheFarm > MFServers > EachIndividualServer

For LSHostName and LSPortNumber

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HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix – values LSName and LSPort.

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HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Licensing

Note: This following screen shot show license information contained in the data store. These values were deleted by Citrix support during analysis of the issue.

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HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\License – Empty

Notes: If the information is accurate and located in the specific registry keys, a Citrix policy that includes licensing information is really not required. There might be other reasons for the 20000 server load. You might need to recreate the Local Host Cache (run dsmaint recreatelhc from a command prompt with the IMA Service stopped and then restart the IMA Service). Removing the Citrix License information from the existing policy would sometimes recreate the non-Licensing related policy values. Do not attempt to add the above registry values if the values in the Data Store are empty. A new policy without licensing information might need to be created. Such policies appear to be retained on subsequent reboots.

If the License Server information was chosen to be added later, the Data Store and Registry values should be empty. You may want to remove all policies entries from the policies created in the Delivery Services Console and use gpedit.msc to create the policies with the desired license server information. The policy information from the registry should be retained on consistent reboots.

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Note: A policy registry key might contain ICAPolicies and IMA:

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Then Licensing is added:

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This information is also located in the Wow6432Node\Policies\Citrix Node. Upon Reboot, all of the Policy information (ICAPolicies and IMA) is missing.

Problem Cause

If the IMAService is unable to contact the Data Store in a timely manner, Citrix Delivery Console Policies are deleted from the registry.

Issue/Introduction

This article contains information to troubleshoot when the XenApp 6 server is unable to contact the license server after a reboot. The output of the Qfarm /load command indicates a server load of 20000.

Additional Information