Connections Fail after Upgrading Online Plug-in

Connections Fail after Upgrading Online Plug-in

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Article ID: CTX125355

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Updated On:

Description

After upgrading Citrix Online Plug-in, you cannot connect to your published resources.

When connecting to XenApp and XenDesktop connections without the connection bar enabled, the following message appears:
“Unable to launch your application. Contact your help desk with the following information: Cannot connect to the Citrix XenApp Server."

The server <XenApp or XenDesktop address> is not trusted for ICA connections.

Alternatively, if the connection bar is enabled, the following message appears:

“The connection to <published resource name> failed with status (1030)"

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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve the issue, complete one of the following solutions:

Solution-1

To reapply the settings from Group Policy:

  1. Click Start > Run, type “cmd” and press Enter.
  2. Run the command gpupdate /force.

The preceding steps reapply the Client Selective Trust settings on the client.

Solution-2

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.
  1. Open the registry editor on the client and go to the following registry key:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Engine\Configuration\Region Identification\Trusted Region\Evidence]
  2. Change the “InternetExplorerZone” string value from “Trusted, Unsupported” to match the settings required in your environment.


Problem Cause

The issue can occur when you apply Client Selective Trust settings through Group Policy. These settings are written to the following locations.

[HKLM \SOFTWARE\Citrix\ICA Client\Engine\Configuration\Region Identification\Trusted Region\Evidence] "EffectiveAddress"="" "InternetExplorerZone"="Trusted,Intranet,Internet”
[HKLM\SOFTWARE\Policies\Citrix\ICA Client\Lockdown Profiles\All Regions\Lockdown\Network\ClientSelectiveTrust] “EnableClientSelectiveTrust”=”true”

When you upgrade the ICA client, the registry key is deleted and the standard settings are recreated.

[HKLM \SOFTWARE\Citrix\ICA Client\]

The following Registry key is not deleted and therefore the settings are incorrect.

[HKLM\Policies\Citrix\ICA Client] 

Issue/Introduction

This article provides resolution to the connections failure issue that occurs after upgrading Online Plug-in