Citrix Online Plug-in 12.0 Ignores Webica.ini Settings

Citrix Online Plug-in 12.0 Ignores Webica.ini Settings

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Article ID: CTX124921

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Description

After installing or upgrading to Citrix Online Plug-in 12.0, the following dialog appears when attempting to access local client resources; in this case local client drives:

“A remote application is trying to access files on your computer.

Do you want to give permission to do this?”

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Resolution

Complete the following steps to resolve the issue:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.
  1. Download the registry settings from CTX124871 - 12.0 Online Web Plug-in Using Single Sign On - SSON Fails with Web Interface and import on a client device (32-bit and 64-bit .reg files are provided).
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Client Selective Trust.

Or

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Client Selective Trust.

  1. In the appropriate region(s), change the (Default) value for any of the following resources according to the list of access values:

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  2. In the appropriate region(s), change the (Default) value of the IsIsmDeferalEnabled key to true, such as:

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Client Selective Trust\oidIntranetRegion\IsIsmDeferalEnabled

Name: (Default)
Type: Reg_SZ
Data: true
Tip: In the Internet region (oidInternetRegion), this step is not necessary.

  1. Export the Client Selective Trust key to a new .reg file (for each 32-bit and 64-bit).

  2. Import the modified .reg file on each client device.

Note: This process can be automated by using a logon script.

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Problem Cause

A new feature and group policy based method, Client Selective Trust, has replaced the previous method of storing client resource permissions in the Webica.ini file. The new method provides customers secure and flexible options for setting client resource permissions by trusted and restricted site regions.

Issue/Introduction

This article contains information to suppress file security permission pop up.

Additional Information

CTX568194 - ICA Client File Security: Web Client Drive Access and the Webica.ini File Explained

CTX133565 - How to Configure Default Device Access Behavior of Receiver, XenDesktop and XenApp