RDP or ICA Direct Desktop Connections Started by Non-Administrative Users Fail

RDP or ICA Direct Desktop Connections Started by Non-Administrative Users Fail

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Article ID: CTX124745

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Updated On:

Description

When starting a Remote Desktop Protocol (RDP) or Independent Computing Architecture (ICA) direct desktop connection on servers with XenApp version 6.x installed, the following error message is displayed to the non-administrative users:
“The desktop you are trying to open is currently unavailable. Contact your administrator to confirm that the correct settings are in place for your client connection.”
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RDP Startup Program connections (RDP initial-applications) also fail with a similar error message.
"The initial application you are trying to open is currently unavailable. Contact your administrator to confirm that the correct settings are in place for your client connection."
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Non-administrative users are able to start the published applications successfully with the Citrix Online Plug-in.

Resolution

Complete the following procedures to resolve the issue:

Changing the Default Unfiltered User Policy Settings for ICA in the Management Console

To change the default unfiltered User policy settings for ICA in the console, complete the following procedure:

  1. Select Policies.

  2. Activate the User tab (you notice the default unfiltered policy).

  3. To access the default policy settings, activate the Settings tab in the lower pane.

  4. Click ICA on the Categories window.

 Allowing Non-administrative Users to Connect to the Server Desktop

To allow non-administrative users to connect to the server desktop, complete the following procedure:

  1. Click the Add link for starting the Desktop Launches.

  2. Select Allowed.

  3. Click OK.

Allowing Non-administrative Users to Start Any Application during Client Connection Select Enabled

To allow non-administrative users to start any application during client connection, complete the following procedure:

  1. Click the Add link for Launching of non-published programs during client connection.

  2. Click Enabled.

  3. Click OK.

 Returning the Settings to the Default Configuration

To return these settings to the default configuration, click the Remove link for the appropriate setting.


Problem Cause

The Citrix default setting that restricts the non-administrative users to start only the published applications was moved from the Independent Computing Architecture (ICA) and RDP listener properties in Terminal Services Configuration to Citrix Policies in XenApp version 6.x. The new policy settings for ICA connections allow the administrator to limit user connections for the desktop, as well as for the published applications.

Issue/Introduction

This article contains resolution to the following errors: - The desktop you are trying to open is currently unavailable. - The initial application you are trying to open is currently unavailable.

Additional Information

CTX121487 - RDP Initial Application Cannot be Started when Connecting to Windows Server 2008 Terminal Server