Citrix Audio Driver not Displayed under Audio Tab in ICA Session

Citrix Audio Driver not Displayed under Audio Tab in ICA Session

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Article ID: CTX124354

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Description

Applications like Windows Media are not audible when connecting through an ICA session.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Complete the following steps to resolve the issue:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

For 32-bit servers

  1. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\Terminal Server\ICA.

  2. Edit the entries for mixer and wave to use icammdrv.dll.
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For 64-bit servers

  1. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\Terminal Server\ICA
    Name: msacm.ctxadpcm
    Type: REG_SZ
    Data: ctxadpcm64.acm

  1. Find Wow6423Node in the registry key and set the wave and mixer values to use icammdrv.dll.
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32\Terminal Server\ICA
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Problem Cause

The sound driver is not displayed under Control Panel > Sounds. Within an ICA session where Control Panel > Sounds is available, the Citrix Audio Driver must be listed under the Audio Tab.
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Issue/Introduction

This article contains information to list the Citrix Audio Driver under Audio Tab within an ICA Session.