Error: "1012: The NetScaler Gateway Plug-in could not start. For more information, see the connection log.(15) or (18)"
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Article ID: CTX122969
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Updated On:
Description
When launching NetScaler Gateway plug-in, the following error message is displayed:
"1012: The NetScaler Gateway Plug-in could not start. For more information, see the connection log.(15)"
When connecting to NetScaler Gateway through NetScaler Gateway plug-in the following error message is displayed:
"1012: The NetScaler Gateway Plug-in could not start. For more information see the connection log.(18)"
The log viewer also displays the following error:
"The correct version of the NDIS driver is not installed".

Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
To resolve this issue, reinstall or repair the NetScaler Gateway plug-in on the workstation exhibiting this issue.
A repair of the NetScaler Gateway plug-in is normally performed from Control Panel > Add/Remove Programs on the workstation. If NetScaler Gateway plug-in is corrupted, then the repair might fail.
If NetScaler Gateway plug-in cannot be reinstalled, then download the Cleanup Tool and run the tool as an administrator. This tool removes all the drivers and plug-ins that requires administrative privileges. Now reinstall the NetScaler Gateway plug-in.
Problem Cause
The NetScaler Gateway plug-in installation on the workstation is corrupted.
Issue/Introduction
When launching NetScaler Gateway plug-in, the following error message is displayed:
"1012: The NetScaler Gateway Plug-in could not start. For more information, see the connection log.(15)"
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