When Modifying Initial Client Drive Mapping in the XenDesktop 5 Environment, Conflict Exists Between XenApp and Presentation Server

When Modifying Initial Client Drive Mapping in the XenDesktop 5 Environment, Conflict Exists Between XenApp and Presentation Server

book

Article ID: CTX122061

calendar_today

Updated On:

Description

When modifying initial client drive mapping in the XenDesktop 5 environment, conflict exists between the XenApp and the Presentation Server.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve this issue, complete the procedure in the following sections:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

XenApp

To resolve the issue in XenApp, create the following Registry Key in the XenApp Server:

Registry Key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix
Value InitialClientDrive
Type REG_SZ with the Drive letter desired, Default is V

This Registry key does not work in the XenDesktop environment. To resolve this issue for XenDesktop requires a different procedure depending whether you are using XenDesktop 4 or XenDesktop 5.

XenDesktop 5

To resolve this issue in XenDesktop 5, complete the following procedure:
Note: This procedure is not applicable to the XenDesktop versions earlier than XenDesktop 5.

  1. In the Virtual Desktop Agent (VDA) registry, create the REG_SZ value named InitialClientDriveLetter in the following location:
    HKLM\Software\Citrix\GroupPolicy\Defaults\IOSettings\
    You might be required to create few parts of this path, for example, add Defaults and IOSettings keys if not exist already.

  2. Set the value of InitialClientDriveLetter to the desired drive letter. Next time when a connection is started to the VDA, the preceding step takes effect.

Note: The preceding procedure must be completed in the VDA or its base image, and not on the DDC.

XenDesktop 4

To resolve this issue in XenDesktop 4, map the drive in the Desktop Delivery Controller by the following procedure:

  1. Run the following command from a command prompt:
    “C:\Program Files\Citrix\Desktop Delivery Controller\PortICASetDefaults.exe" /o c:/xml-original.xml

  1. Browse to the c:/xml-original.xml file.

  2. Open the file and find the following value:
    <InitialClientDrive>V</InitialClientDrive>

  1. Modify V to the desired drive Letter (example, M).

  2. Save the XML file with the changes.

  3. Run the following command to write the changes made to the xml file back to the DDC:
    “C:\Program Files\Citrix\Desktop Delivery Controller\PortICASetDefaults.exe"/i c:/xml-original.xml

  1. Run the following command to create the.xml file to verify the changes:
    "C:\Program Files\Citrix\Desktop Delivery Controller\PortICASetDefaults.exe" /o c:/xml-originalv2.xml

  1. Open the file and confirm that the changes were made:
    <InitialClientDrive>M</InitialClientDrive>

  2. Start a new session and note that the mapped drive must now start with M instead of V.

Problem Cause

InitialClientDrive defines the first letter of the drive to be used for the client drive mapping and works backward through the alphabet from this letter to map client drives that could not be mapped to their native drive letters as explained in the following examples:

  • VDA local drives: C:, D:, T:
    Client has drives C:, D:, E:
    InitialClientDrive is set to: V: (the new default)
    In this particular example, drive V is mapped to the client drive C, drive U is mapped to the client drive D, and drive S is mapped to the client drive E because drive T is already in use on the VDA.

  • VDA local drives: E:, F:
    Client has drives: C:, D:, E:
    InitialClientDrive is set to: V: (the new default)
    In this example, drive C is mapped to the client drive C, drive D is mapped to the client drive D, and drive V is mapped to the client drive E.

Issue/Introduction

When modifying initial client drive mapping in the XenDesktop 5 environment, conflict exists between the XenApp and the Presentation Server.

Additional Information

CTX238200 - How to Troubleshoot Client Drive Mapping

Citrix TV contains the following video for the XenDesktop 4 content of this article:
http://www.citrix.com/tv/#videos/1598
Duration: 2:53 minutes
Note: This video requires the Adobe Flash player plug-in for the Web browser.