Error: "The Network Connection to your Application was Interrupted" on ICA Client
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Article ID: CTX115648
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Description
A published application does not start and the following error message is displayed:
“The network connection to your application was interrupted. Try to access your application later, or contact technical support.”
Resolution
To resolve the issue, complete one of the following procedures:
- Resolving Licensing Issues
- Resolving Kerberos Authentication Issues
Resolve Licensing Issues
Refer to the Knowledge Center article CTX564283 –
Troubleshooting 1003 and 1004 Terminal Server Licensing Errors to troubleshoot the possible licensing issues
.
Resolve Kerberos Authentication Issues
To fix issues related to Kerberos authentication, complete the following procedure:
-
Disable Kerberos on the ICA Client.
-
Set SSPIEnabled = Off in the wfclient.ini file in the \Program Files\citrix\ica client folder and in the user’s profile in the \Documents and Settings\username\Application Data\ICAClient folder.
-
Close and restart the ICA Client.
Problem Cause
Licensing issues might be preventing the user to connect to the application Issues with Kerberos authentication.
The error is displayed when pass-through authentication is enabled on the ICA Client.
If explicit authentication is used, the error message is not displayed.
Issue/Introduction
A published application does not start and the error message appears, “The network connection to your application was interrupted. Try to access your application later, or contact technical support.”
Additional Information
RD Licensing formerly Terminal Services Licensing (TS Licensing), manages the Remote Desktop Services client access licenses (RDS CALs) that are required for each device or user to connect to a Remote Desktop Session Host (RD Session Host) server
Broker Database would have a new table for maintaining RDS CAL as a key/value pair. On a non-Windows client connection to a TS VDA, if a license is checked out, ICA populates the registry entries. Behaviour on following session events is described below:
HKLM\Software\Citrix\MSLicensig\ReplicateCache registry key and corresponding nodes under HKLM\Software\Citrix\MSLicensig registry key to check if any of the licenses has same index as RdsCalId.
HKLM\Software\Citrix\MSLicensig\ReplicateCache registry key and corresponding nodes under HKLM\Software\Citrix\MSLicensing registry key. For each node under HKLM\Software\Citrix\MSLicensig\ReplicateCache registry key, Stack Control would read license information from corresponding node under HKLM\Software\Citrix\MSLicensing, create a blob of byte array and write license information to the blob.
Create node and write license information to node under HKLM\Software\Citrix\MSLicensing
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