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Article ID: CTX558911
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Updated On:
Description
After adding Citrix Gateway URL on Workspace App and entering the credentials, the users encounter the error "Unable to connect to the server. Check your network connection and retry."

Resolution
Change the naming format of the PNG image from Chinese to English.
Problem Cause
The customized PNG image file on Storefront is named with Chinese format, which is not supported by Workspace.
Analysis Detail:
- In NetScaler nstrace(Pic.1)
- The requests circled with red bracket below tells Workspace is trying to download a PNG image file from Strorefront via NetScaler Gateway.
- The PNG image is customized on Storefront by the customer with both content and file name changed.
- After that, no more client request received in NetScaler any more.
Pic.1
- Workspace Client CDF trace log:
- "Illegal characters in path" error found.
2023/05/24 11:14:03:21845,1108,612,1,Receiver_SelfService_web ,,0,,3,Error,"Exception when downloading offline webUI file http://storefrontfqdn/Citrix/StoreWeb/custom/340x80_書法字1.png",""
2023/05/24 11:14:03:21846,1108,612,1,Receiver_SelfService_web ,,0,,3,Error,"Illegal characters in path.",""