Citrix cloud session launch shows "There is a problem with your Remote Desktop license"

Citrix cloud session launch shows "There is a problem with your Remote Desktop license"

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Article ID: CTX478251

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Updated On:

Description

An ICA application or Desktop launch on Citrix cloud gives a RDS Pop-up message as 

"Remote Desktop License Issue 
There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes. Contact your system administrator to fix this problem. "

Resolution

Create a new Delivery Group and ensure to uncheck the box “Allow users not in Active directory to use this delivery group”

Problem Cause

Delivery group checkbox setting “Allow users not in Active directory to use this delivery group.” This causes a user application launch to be authenticated twice. First as domain users then next as local users. As the user logs in as a Local user, Local users are not allowed to obtain an RDS license. 

Issue/Introduction

An ICA application or Desktop launch on Citrix cloud gives a Pop-up message as  "Remote Desktop License Issue  There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes. Contact your system administrator to fix this problem. "

Additional Information

For more details on the Authenticated and unauthenticated users refer https://docs.citrix.com/en-us/citrix-daas/install-configure/delivery-groups-create.html#authenticated-and-unauthenticated-users