Citrix Receiver gives error "HDX Engine Stopped Working"

Citrix Receiver gives error "HDX Engine Stopped Working"

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Article ID: CTX228862

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information

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Resolution

Disable DirectX Video Acceleration in Receiver (by default, it is ON) to resolve the "HDX Engine stopped working" issue.

Follow below steps to Disable DirectX Video Acceleration in Receiver.
 - Set Receiver local policy "Hardware Acceleration for graphics" as "Disabled"

Problem Cause

Exception is triggered while pointing to an invalid memory location. Last function on the call stack belongs to Intel and hence we are not able to load the parameters(Unable to Debug Intel Code).

Intel drivers are old and cannot be upgraded and they are running with latest version.

Issue/Introduction

Whenever trying to open a session, the session comes up, but immediately crashes saying "HDX Engine stopped working" and all we can do is stop it and the session gets closed.

Additional Information

Please refer the article below to know how to disable hardware acceleration for graphics:
https://docs.citrix.com/en-us/receiver/windows/current-release/improve.html#:~:text=Under%20the%20Computer%20Configuration%20node,and%20click%20Apply%20and%20OK.

Forum article:
https://discussions.citrix.com/topic/385886-hdx-engine-stopped-working