Optional VPP Apps show "Mismatch between user and device iTunes store account hashes"

Optional VPP Apps show "Mismatch between user and device iTunes store account hashes"

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Article ID: CTX226099

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Updated On:

Description

The following error is seen when inspecting the Delivery Group details of an Apple device on the MDM server console: "Mismatch between user and device iTunes store account hashes".

Attempts to send installation commands for VPP apps from the MDM server to the Apple device can fail.

Optional VPP app fail to install on Apple devices 

Resolution

Retire the VPP user by following the instructions at https://docs.citrix.com/en-us/citrix-endpoint-management/apps/apple-volume-purchase.html#retire-a-user-from-the-volume-purchase-account

This will allow for the VPP licenses to first be recovered (using the step above) and then later the VPP license can be reissued again. This will cause the user to receive a new email invite, repairing the mismatch between user and device iTunes store account hashes.

Problem Cause

This problem is caused when the user iTunes Store account hash no longer matches with the device iTunes Store account hash. Use the Retire VPP User functionality to reset such mismatched hashes.

Issue/Introduction

Error: Mismatch between user and device iTunes store account hashes