M365 Applications are Prompting for Authentication for New VDAs in an Existing Catalog. Older VDAs in the same catalog are not affected.
User profile management is handled by FSLogix.
Looking at the Event Logs under: Application and Services -> Microsoft ->Windows->AAD Shows an error with EventID 1098 containing the following:
Error code 0xCAA2000C : "The request requires user interaction"
AADSTS50076: Due to a configuration change made by your administrator, or because you moved to a new location, you must use multifactor authentication to access.
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Error code 0xCAA2000C : "The request requires user interaction" can occur when Microsoft Entra ID tries to perform a Single Sign-in for an app but a Conditional Access policy enforcing Multi-Factor Authentication (MFA) blocks it.
There was a Conditional Access policy to enforce Multi-Factor Authentication (MFA) that had an exclusion for the working VDAs.
Adding the non-working VDAs to the exclusion list resolved the issue.
M365 Applications are Prompting for Authentication for New VDAs in an Existing Catalog. Older VDAs are not affected.
For more information on this error see: https://learn.microsoft.com/en-us/troubleshoot/mem/intune/comanage-configmgr/troubleshoot-co-management-auto-enrolling#microsoft-entra-hybrid-joined-devices-fail-to-enroll-and-generate-error-0x8018002a