CVAD - Locking client desktop causes session to disconnect

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Article ID: CTX696656

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Updated On:

Description

HDX session gets disconnected as soon as the user clicks ‘Lock’ inside the desktop. Session. 

User clicks on Start > Username > Lock . Then the Desktop is disconnected instead of locked. 

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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it. 

Cause

CDF traces show the following. 

 

11:19:13:20982,12772,13300,Unknown,-1,Citrix.Authentication.VirtualSmartcard,,0,,,5,Information,"Configuration::IsVirtualSmartcardDisconnectOnLock [True]","" 

 

There is a Smart-card removal policy on clients with these possible values and their meanings. 

None (no effect)
Lock Workstation (disconnects all user sessions)
Force Logoff (logs off all user sessions)

 

Trace shows that the Policy action is currently set to “Lock WorkStation” which disconnects the session.

Resolution

Set the “Smart Card Removal” policy action to None or else set this registry key on the client .  

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\Authentication\VirtualSmartcard] "DisconnectOnLock"=dword:00000000 

Issue/Introduction

HDX session gets disconnected as soon as the user clicks ‘Lock’ inside the desktop.