Citrix Workspace App fails to launch desktops when App Protection is enabled

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Article ID: CTX696654

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Updated On:

Description

Citrix Workspace App is installed on a Windows 10 / Windows 11 computer without selecting the option "Start App Protection after installation"

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As a result "App Protection service" is set to Manual and not running

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When user tries to launch a desktop that is configured to be launch with App Protection, it fails with error "Unable to establish secure environment using App Protection"

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User can start manually the "App Protection service" as a workaround to launch the desktop

Cause

 

When App Protection service is not running and user launches a protected desktop, the process UpdaterService.exe is responsible to set the "App Protection service" as Automatic and start the service, for the launch to succeed

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UpdaterService.exe process is started when "Citrix Workspace Advanced Service" (CWAUpdaterService) is Running

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If the "Citrix Workspace Advanced Service" is disable, it will not start the "App Protection service", and the protected desktop will fail to launch

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Resolution

Enable and set the "Citrix Workspace Advanced Service" as Automatic

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Issue/Introduction

Citrix Workspace App fails to launch desktops when App Protection is enabled after installing it without the option "Start App Protection after installation"