Citrix Director - unable to shadow session (remote assist)

book

Article ID: CTX696597

calendar_today

Updated On:

Description

The environment has been patched with the latest updates mentioned in the article: https://support.citrix.com/external/article/CTX695983

Attempt to shadow the session fails with the error:

image.png

Invite file cannot be downloaded from Director.

Event viewer on the Director server shows the error:

  • Log Name: Application
  • Source: Citrix Director Service
  • Event Id: 2
An unexpected error occurred when accessing the data source 'The broker service reported an error. See the event log for more information.' ('http://DDC_FQDN/Citrix/BrokerAdminService/v2').

User: DOMAIN\USER
Console operation: 'Starting remote assistance for desktop…'

Additional information:
'The request channel timed out while waiting for a reply after 00:00:20. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.'

 

On the VDA (inside the ICA session); Windows Remote Assistance window appears:

image.png

 

Attempt to save the invite file on the VDA also fails with the same message.

This can be tested by running (from Start > Run or cmd.exe):

msra /saveasfile Test 12345678910

(Test is the name of the file and 12345678910 is the password).

 

 

 

 

Cause

“Configure Solicited Remote Assistance” policy has been Disabled.

Resolution

Check Registry (regedit) on the VDA:

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\

The value of interest: fAllowToGetHelp

If it is set to 0; this means that Solicited Remote Assistance has been disabled.

 

Example:

image.png

Check local or domain policy (gpedit.msc):

Computer Configuration > Administrative Templates > System > Remote Assistance

image.png

 

Enable the policy

If you enable this policy setting, users on this computer can use email or file transfer to ask someone for help.

Issue/Introduction

The purpose of this article is to help customers to identify and resolve the issue with shadowing.