uberAgent does not honor custom log path setting

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Article ID: CTX696591

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Updated On:

Description

By default on Windows, uberAgent writes its logs to %TEMP%, which typically resolves to C:\Windows\Temp\.

Customers can change this location as described in the product documentation.When using any of the following versions, the custom log path setting is not applied and uberAgent continues to log to C:\Windows\Temp\:
  • uberAgent 7.4.2
  • uberAgent 7.5.0
  • uberAgent 7.5.1
  • uberAgent 7.5.2
  • uberAgent 8.0

Cause

Due to a bug in the affected versions, registry-based configuration for the custom log path must be explicitly enabled via the EnableThisConfig registry value.

Resolution

  1. Configure the custom log path as described in the product documentation. 
  2. In the registry (Caution! Refer to the Disclaimer at the end of this article before using the Registry Editor.), under:HKEY_LOCAL_MACHINE\SOFTWARE\vast limits\uberAgentadd aDWORDvalue namedEnableThisConfigand set its data to1.
  3. Restart the uberAgent service.After the restart, uberAgent should write logs to the location specified by LogPath.

    Please note: the EnableThisConfig value underHKEY_LOCAL_MACHINE\SOFTWARE\vast limits\uberAgentis no longer required starting with uberAgent 8.1.

Issue/Introduction

The purpose of this article is to help customers to change the default log file location.

Additional Information

"Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it."