CWA for MAC - MS Teams screen alignment issue on VDI when connecting from Mac client

book

Article ID: CTX696577

calendar_today

Updated On:

Description

When connecting from MAC Client to Windows VDI and use MS Teams inside the ICA Session, the video on the MS Teams call may not be properly aligned within the teams window if either High DPI is enabled or if 100% scaling is used on the client side. The actual video may be displayed larger than the window portion for the video. When using low-res display (FHD for example)  or when using Native resolution the problem may not be seen.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Cause

High DPI Matching support was disabled on the VDA side.

Resolution

Enabling DPI Support on the VDA should fix this problem. This can be done by setting the EnableDPISupport registry key to 1. 

Location: HKLM\SOFTWARE\Citrix\Graphics
Name: EnableDpiSupport
Type: DWORD
Value: 1

Issue/Introduction

When connecting from MAC Client to Windows VDI and use MS Teams inside the ICA Session, the video on the MS Teams call may not be properly aligned within the teams window if either High DPI is enabled or if 100% scaling is used on the client side. When using low-res display (FHD for example)  or when using Native resolution the problem may not be seen.