uberAgent - LAS activation issue with code: 6

book

Article ID: CTX696573

calendar_today

Updated On:

Description

The uberAgent service is not running on the machine and cannot be started.

uberAgent.log located in C:\Windows\temp shows that service is shutting down because of licensing issue:

ReadConfiguration,No license or integration mode detected. Shutting down.

 

Attempt to activate with LAS:

7.5.1.7185

CallLASRestAPI,Using generated CCAuth service key for Authorization header
CallLASRestAPI,Using customerId from activation request data
CallLASRestAPI,LAS request URL: https://api-us.cloud.com/lasuberagent/activate
CallLASRestAPI,LAS request headers count: 4
CallLASRestAPI,Header[0]: Authorization: [MASKED]
CallLASRestAPI,Header[1]: Citrix-CustomerId: TENANT ID
CallLASRestAPI,Header[2]: Content-Type: application/json
CallLASRestAPI,Header[3]: Accept: application/json
PostDataToPage,curl_easy_perform failed with code: 6
CallLASRestAPI,Failed to send activation data.

 

8.0.7535

LAS,HK::Licensing::Token::TokenLicenseManager::CallLASRestAPI,LAS request URL: https://api-us.cloud.com/lasuberagent/activate
PostDataToPage,curl_easy_perform failed with code: 6

 

If we check the error code from this line: PostDataToPage,curl_easy_perform failed with code: 6
From CURL documentation:

CURLE_COULDNT_RESOLVE_HOST (6)
Could not resolve host. The given remote host was not resolved.

This indicates that here is an issue with DNS resolution

DNS resolution check
cmd.exe:

nslookup api-us.cloud.com DNS Server can't find api-us.cloud.com: Non-existent domain

Cause

DNS resolution issue.

Resolution

Make sure that DNS resolution is working.

URL used as per Citrix documentation:

HTTPS https://api.cloud.com US, EU, APS
HTTPS https://api-us.cloud.com US, EU, APS
HTTPS https://api.citrixcloud.jp Japan

In some environments proxy configuration might be required, please review:
https://docs.citrix.com/en-us/uberagent/7-5-x/kb/architecture/using-uberagent-with-a-proxy.html

 

Issue/Introduction

The purpose of this article is to help customers to troubleshoot and resolve issues with uberAgent and LAS activation.
The steps apply to machines where Citrix VDA software is not installed.

Additional Information

uberAgent documentation: 

https://docs.citrix.com/en-us/uberagent/7-5-x/planning/firewall-and-antivirus-exclusions

 

https://docs.citrix.com/en-us/uberagent/7-5-x/kb/architecture/using-uberagent-with-a-proxy.html