Citrix WEM Infrastructure Service Will Not Start With the Error: LICENSING: Unexpected Error In Initializing LAS Policy Engine.

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Article ID: CTX696571

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Updated On:

Description

  • Citrix WEM Infrastructure service not starting after Migrating to LAS.
  • Restarting the service causes it to stop within a few seconds and in the WEM Infrastructure Service event logs we see the following error:
Event ID:      0
Level:         Error
Description: LICENSING: Unexpected Error In Initializing LAS Policy Engine.... Error: Access to the path 'C:\Program Files (x86)\Citrix\Workspace Environment Management Infrastructure Services\Licensing\Las' is denied.
  • The folder: C:\Program Files (x86)\Citrix\Workspace Environment Management Infrastructure Services\Licensing\Las does not exist
  • The WEM Infrastructure service is running under a gMSA account.
  • CVAD has been migrated to LAS and is functioning correctly.

 

Cause

The service account running the WEM Infrastructure service did not have write permissions to the path: C:\Program Files (x86)\Citrix\Workspace Environment Management Infrastructure Services\Licensing so it was unable to create the LAS folder containing the licensing blobs.

Resolution

Adding NTFS Read, Write and Read & Execute permissions for the gMSA account to the folder: C:\Program Files (x86)\Citrix\Workspace Environment Management Infrastructure Services\Licensing resolved the issue.

Issue/Introduction

Citrix WEM Infrastructure service will not start with the error: "LICENSING: Unexpected Error In Initializing LAS Policy Engine.... Error: Access to the path 'C:\Program Files (x86)\Citrix\Workspace Environment Management Infrastructure Services\Licensing\Las' is denied."

 

Additional Information

Group Managed Service Account for WEM Infrastructure services: https://docs.citrix.com/en-us/workspace-environment-management/current-release/install-and-configure/infrastructure-services.html#group-managed-service-account