Citrix Virtual Desktops and Applications - Windows VDA stuck at negotiating capabilities

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Article ID: CTX696547

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Updated On:

Description

In a Citrix DaaS hybrid environment, users may notice that the Windows VDA gets stuck at "Connection established, negotiating capabilities" phase when connecting from Cloud portal.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Cause

When implementing registry key change via group policy, the wrong type was chosen by mistake.

Resolution

Changing the registry value Type of UviProcessExcludes from REG_MULTI_SZ to REG_SZ resolved the problem.

HKLM\System\CurrentControlSet\Services\CtxUvi

Value Name: UviProcessExcludes

Type:  REG_SZ

Issue/Introduction

In a Citrix DaaS hybrid environment, users may notice that the Windows VDA gets stuck at "Connection established, negotiating capabilities" phase when connecting from Cloud portal.