Citrix DAAS - > Failed to create MCS catalog with error “Failed to create a computer account <machine_name> due to FailedToExecuteSearchInAD.

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Article ID: CTX696525

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Updated On:

Description

Issue consistently occurs when selecting “Create new AD account” during machine provisioning but does not occur with “Use existing AD accounts”. 

Deleting machines from catalog successfully removes AD objects. 

Issue occurs only during automatic AD account creation. 

Cloud Connector computer accounts  have the required permissions (Full Control) on the target OU.     

 

Cause

You cannot use the Citrix Connector Appliance (the Linux-based virtual appliance) for MCS. 

For Machine Creation Services (MCS) to work with an on-premises or private cloud resource location, you must use the Windows-based Citrix Cloud Connector. 

Resolution

  • Navigate to the Identity and Access Management menu (found in the top-left "hamburger" icon) of DAAS Console.
  • Click on the Domains tab. 
  • Locate your domain and click the three dots (...) at the end of the row. 
  • Select Change Connector Type (or Edit Domain, then look for the "Connection" settings). 
  • Toggle the selection from   Connector Appliance  to Cloud Connector 
  • Save/Confirm. 

 

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Issue/Introduction

Customer is unable to create machines in Citrix DaaS MCS Catalog with this error

"Failed to create a computer account <machine_name>, due to FailedToExecuteSearchInAD.” 

This is seen with “Create new Active Directory account” option.