Studio Warning "Your software maintenance has expired" post LAS migration

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Article ID: CTX696515

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Updated On:

Description

End users

  • The CVAD notification message is shown when a desktop session is launched if the License Server has any expired entitlement installed—CVAD or non‑CVAD (for example, PVS) -- even when another valid entitlement (with a different expiry date) exists.

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Admins (Studio)

  • The Studio warning message is shown when a CVAD or non‑CVAD entitlement expires or is expiring within 30 days -- even when another valid CVAD entitlement exists.

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  • When this issue is triggered, the event viewer will have Broker Service 1205 event:

    Your software maintenance has expired.

        Your Citrix environment is currently unsupported. Please check your license server for expired licenses and remove them.
        There is a 30-day license caching mode before users start getting warning messages.

Desired behavior:

  • End users: Show the CVAD notification message only when all CVAD entitlements are expired.
  • Admins (Studio): Show the Studio warning message only when all CVAD entitlements are expired or expiring within 30 days.


For a CVAD admin, this PowerShell can output what is expiring/expired:

Get-BrokerSite | Select LicensesWithExpiredSwm   

Cause

Issue identified in the product.

Resolution

Refer to the below links to access the Hotfixes for different LAS compatible Delivery Controller versions:

Note: If the DLL's are blocked, follow the below steps to unblock them:

  1. Validate download source of the hotfix package
  2. Validate the checksums (like SHA-256 hashes), compare them with the  SHA-256 hashes listed in individual articles listed below.
  3. Check digital signatures in properties (on Windows: Properties → Digital Signatures tab).
  4. Unblock the files only if you trust then, then proceed with the copy/install steps, mentioned in the below articles.

These privates replace the ones provided under CTX696464

2203 LTSR CU7 Update 2

2402 LTSR CU3 Update 2

2507 LTSR Update 2

2507 LTSR CU1 Update 3

2511 Update 3

 

Issue/Introduction

End users may see notification messages during session launch, and administrators may see alerts in Studio, if the License Server contains expired entitlements (either installed locally or received from the License Activation Service). These warnings can also trigger if the server holds a mix of fully active entitlements and ones that are nearing expiration.