Citrix Licensing - Error registering license server “The license server is still registered with Citrix Cloud. Remove the registration from Citrix Cloud before registering again”

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Article ID: CTX696506

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Updated On:

Description

The License Server instance is already registered in Citrix Cloud.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it. 

Cause

This error is seen in C:\Program Files (x86)\Citrix\Licensing\WebServicesForLicensing\Logs\ log_activator.log.

response={{"Error":{"Message":"Repeated entry found. Change the instance ID","Type":"INSTANCEID_NOT_UNIQUE"}} 

 

The Instance ID is shown in the log_activator.log 

body={"ver":"1.0","service":"licenseserver","instanceID":"a1f7ac54-xxxx-xxxx-xxxx-b5ce3cb89987","publicKey":"PFJTQUtleVZhbHVlPjxNb2R1bHVzPnVCajZCMGptUEh0Mm9ETDF1bFo5TDQ2amxMRHRUYjc4eGNxb3E4OVdPVTVTa0pNMUJXWUVNN1VQVlJnRVByVWkzaEkrbUQvRWpJU3JjL2JoQUtFcmVhdFpqNk8zaTM4MllGekYzTm53TFNQVDdoTUwwdUN6K2V0UkQyMzlROGlMWUZpai9BTmVrSENzT29ZaXVRVFRwKzFBSUxscmRmM2liRG5yQmQ2REtCOU5iNmVMMEQxN1krbGlPM1czckkvbTlORW1pMmpaV2VBVmJlc3A2NTNtNWU2VlhBUGRjQ2RzbEt5RklHZDdLckdGRXo4YU8xSldhbzlpb2dHMXNDcmlmV2 

 

The error is returned from LAS in Citrix Cloud and indicates there the license server instance was previously registered. 

To confirm the current instance ID check the citrix.opt file . 

#CITRIX CEIP DIAG 

#CITRIX LSINFO a1f7ac54xxxxxxxxxxxxcb5ce3cb89987 

#CITRIX LSINFO_UNID 1d8b0e0b1aa9418c8xxxxxxxxxxx 

#CITRIX LAS_ORGID xxxxxxxx 

Resolution

First ensure there is no existing registration. 

Log into Citrix Cloud:  

Access the Citrix Cloud console using your administrator credentials.  

Navigate to API Access:  

Go to Identity and Access Management. 

Click on the API Access tab.  

Access Product Registrations:  

In the API Access section, select Product Registrations.  

Lis the License Server in the list of registered products? 

If so, remove the License Server Registration and try again. 

If the license server is not present in Product Registrations then the quickest resolution is to uninstalll and do a clean install of the license server . 

This will ensure that a new Instance ID is created for the License Server. 

Reinstall License Server Component  

Back up all license files 

Uninstall the License Server component 

Remove any leftover Licensing folders under: 
C:\Program Files (x86)\Citrix\ 

Delete HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\MetaInstall\Mac 

Reinstall Citrix Licensing 

 

Then check the citrix.opt file and confirm that the instance ID has changed. 

Attempt registration. 

 

Issue/Introduction

Failed to register the Citrix License Server with Citrix License Activation Service.  After clicking on Register button the following appears.

“The license server is still registered with Citrix Cloud. Remove the registration from Citrix Cloud before registering again”