10-Bit High Dynamic Range sessions might fallback to 8-bit on Nvidia Blackwell client GPUs

book

Article ID: CTX696450

calendar_today

Updated On:

Description

Affected Environment 

  • Citrix Workspace app for Windows (32‑bit / x86).
  • Endpoints with NVIDIA GPUs.
  • HDR or 10‑bit color sessions (for example, H.265 4:4:4 10‑bit).
  • Nvidia GeForce RTX 50 series (Blackwell) and newer.

Cause

The 32‑bit (x86) Citrix Workspace app for Windows is unable to decode H.265 4:4:4 10‑bit video streams using NVIDIA GPU hardware decoding on Nvidia Blackwell-series GPUs. 

When the client cannot decode the negotiated 10‑bit stream, the session automatically and silently falls back to 8‑bit color depth. This fallback behavior is by design to ensure session continuity, but it results in a degraded visual experience on HDR‑capable displays. 

This limitation is specific to Nvidia GPUs when used with the 32‑bit Citrix Workspace app for Windows. 

Resolution

The issue has been resolved in the x64 (64-bit) version of the Citrix Workspace App for Windows. Customers experiencing this issue are advised to migrate to the 64‑bit Citrix Workspace app for Windows on endpoints with affected Nvidia GPUs. 

Citrix does not plan to address this limitation in the 32‑bit (x86) version of the Citrix Workspace app for Windows. 

Issue/Introduction

Sessions configured for High Dynamic Range (HDR) and 10‑bit color, do not operate in 10‑bit color depth and instead silently fall back to 8‑bit color on client endpoints with Nvidia GeForce RTX 50 series (Blackwell) GPUs.

When this occurs, users may notice visibly reduced image quality, such as washed‑out colors or banding, when HDR is enabled for use in the session on HDR‑capable monitors. 

This issue is observed only on endpoints with Nvidia GeForce RTX 50 series (Blackwell) and newer GPUs.

Additional Information

More information about 10-bit colour:

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/graphics/introduction/10-bit-high-dynamic-range-introduction.html

Details on the availability and transition to the x64 CWA version:

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/transition-to-64-bit-faq.html