Citrix Storefront - Invalid STA port 8090 added during upgrade

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Article ID: CTX696339

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Updated On:

Description

Symptoms:

  • Port might be added to the STA / Cloud Connector URL after upgrade
  • Invalid port added: 8090
  • The issue occurs after upgrade from an older version (2407/2411) to 2507, 2507 CU1
  • This only affects the gateway type: Citrix Gateway Service
  • Web.config located in C:\inetpub\wwwroot\Citrix\Roaming shows that both URLs (secureticketauthorityurls and cloudGatewayConfig) have port 8090 configured.

 

Example:

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Config file:

          <secureticketauthorityurls>
            <location path="http://connector.domain.local:8090/scripts/ctxsta.dll"
              staValidationEnabled="off" staValidationSecret="" />
            <location path="http://connector2.domain.local:8090/scripts/ctxsta.dll"
              staValidationEnabled="off" staValidationSecret="" />
          </secureticketauthorityurls>
          <cloudGatewayConfig>
            <clear />
            <add url="http://connector.domain.local:8090/Control/GatewayConfig/v1" />
            <add url="http://connector2.domain.local:8090/Control/GatewayConfig/v1" />
          </cloudGatewayConfig>

 

Cause

In 2407 release, cloudGatewayConfig URL was configured with port 8090. Secureticketauthorityurls URL did not have the port configured.

          <secureticketauthorityurls>
            <location path="http://cloudconnector.local/scripts/ctxsta.dll"
              staValidationEnabled="off" staValidationSecret="" />
          </secureticketauthorityurls>
          <cloudGatewayConfig>
            <clear />
            <add url="http://cloudconnector.local:8090/Control/GatewayConfig/v1" />
          </cloudGatewayConfig>

There was a change added to the 2503 version of Storefront. The purpose of the change was to have both URLs with the same port (secureticketauthorityurls and cloudGatewayConfig).

 

Resolution

Remove port 8090 from the Cloud Connector URL.

  • In Storefront console, go to the Manage Citrix Gateways
  • Select Affected Gateway and click on EDIT
  • Go to Cloud Connectors
  • Select Cloud Connector URL and click on EDIT
  • Remove the port
  • Apply changes.

 

 

Issue/Introduction

The purpose of this article is to describe an issue which might occur after upgrade from an older version of Storefront.

Additional Information

Customers should not encounter this issue during further upgrades.

The issue does not occur when a new Citrix Gateway is configured in Storefront after upgrade.