Hosting Connections in Maintenance Mode after LAS migration

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Article ID: CTX696311

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Updated On:

Description

Environment:

This potential issue may be triggered when the below conditions are met:

  1. Before LAS migration, customers have cloud-based hypervisor connections for VDA provisioning and management
    2. Before LAS migration, customers do not have an XDT_PLT_CCS (with SaaS component) legacy license.

Cause

After LAS migration, SaaS attribute of the XDT_PLT_CCS entitlement, which was previously cached as False in legacy licensing. This value needs to be reset and rechecked after LAS migration.

Resolution

1. Run Get-ConfigSite and confirm SaaSEnabled is False.

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2. Identify the Delivery Controller which runs FeatureChecks site service:

Get-BrokerController | Where-Object { $_.ActiveSiteServices -contains "FeatureChecks" } | Select-Object MachineName, DNSName

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3. Restart Citrix Broker Service on this Delivery Controller.

4. Wait for approximately 10 minutes, and check Get-ConfigSite and confirm SaaSEnabled is True.

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5. Identify the Delivery Controller which runs hypervisor connection site service:

5.1 Get-BrokerHypervisorConnection | select Name to get the name of hypervisor connection

5.2 Get-BrokerController | Where-Object { $_.ActiveSiteServices -contains "name of hypervisor connection" } | Select-Object MachineName, DNSName

For example, “testlas” is the hypervisor connection name in this site:

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6. Restart Citrix host service from the Delivery Controller from step 5.2

7. Check from Citrix Studio and confirm that cloud hypervisor connections are out of maintenance mode.

Issue/Introduction

Cloud-based hypervisor connections go to maintenance mode after a Citrix Virtual Apps and Desktops site migrates to LAS.