Citrix Virtual Apps and Desktops - Failure to launch resources after installing Edge and Chrome browser updates

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Article ID: CTX696276

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Updated On:

Description

Launching of published resources using Edge or Chrome browser may fail after installing updates for the browsers. 

Impacted users may see some or all of the following:

Errors such as web extension required (if app protection is enabled)
Multiple launch attempts for resources
Client Detection failures resulting in ICA file being downloaded rather than session launch
Affected versions:

Google Chrome: 145.x.xxxx.xxx
Microsoft Edge: 145.x.xxxx.xxx

Cause

Recent changes to Chrome’s built-in messaging API enforces closing of communication channel under certain circumstances. This caused the web extension communication with the browser to break.

Resolution

 If you are using Chrome browser, please install the newly released Citrix Web Extension version 26.12 from the Chrome web store. 

Citrix Web Extension - Chrome Web Store

If you are using Edge browser,  please install the newly released Citrix Web Extension version 26.12 from the Edge Web store:

Citrix Web Extension - Microsoft Edge Addons

Issue/Introduction

Launching of published resources using Edge or Chrome browser may fail after installing latest updates for the browsers. 

Impacted users may see some or all of the following:

Errors such as web extension required (if app protection is enabled)
Multiple launch attempts for resources
Client Detection failures resulting in ICA file being downloaded rather than session launch

Additional Information

For additional information regarding web extension, please refer to https://docs.citrix.com/en-us/citrix-workspace/workspace-web-extensions.html