Audio redirection does not work when users connect using Citrix Workspace App 2511 to VDA 2507 on WS2022

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Article ID: CTX696153

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Updated On:

Description

  • The audio issue is reproducible on Citrix Workspace App 25.11
  • Symptoms include poor and distorted audio output, while the microphone works correctly
  • When UDP is enabled and Loss tolerant mode for audio is set to Prohibited, audio works as expected
  • The behavior appears to be triggered when Loss tolerant mode for audio is enabled in combination with Workspace App 25.11

Environment

"Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it."

Cause

loss-tolerant setting was manualy disabled in registry 

Resolution

Starting with 2311.1 release, Citrix Workspace app uses loss tolerant mode for audio redirection.

on VDA  the audio quality enhancer is enabled by default for adaptive audio.

Note: Both adaptive audio and loss tolerant mode for audio must be enabled for this feature to work.

"Enable loss tolerant mode for audio" Policy  and check the registry:

if it doesnot exist, please create and reboot VDA 

For Multi-session VDA:

  • Key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\Audio
  • Value name: EdtUnreliableAllowed
  • Value type: DWORD
  • Value data: 1

 

For Workstation VDA:

  • Key: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Audio
  • Value name: EdtUnreliableAllowed
  • Value type: DWORD
  • Value data: 1

Issue/Introduction

Audio redirection does not work when users connect using Citrix Workspace App 2511 (Windows) to VDA 2507 CU1 on Windows Server 2022 in an on-premises