CWA for Windows 2511 - Server-side IME might not respond to the client-side Korean/English toggle key

book

Article ID: CTX696062

calendar_today

Updated On:

Description

After launching a virtual desktop or application session by CWA for Windows 2511 with the default keyboard layout synchronization setting "Sync only once - when session launches", the server-side IME might not respond to the Korean/English toggle key in the client-side physical keyboard. Ideally, the server-side IME should be able to switch between English and Korean language by pressing the client-side Korean/English toggle key. The issue doesn't occur prior to CWA for Windows 2511

Cause

On the client machines with Windows "Previous version of Microsoft IME" option enabled for Korean keyboard language, CWA for Windows 2511 might fail to deliver 'keydown' event of the Korean/English toggle key to ICA session. That results in server-side IME bar not responding to the client-side Korean/English toggle key.

Resolution

A permanent fix will be available in the near future CWA for Windows release to address the issue.
As a temporary workaround, please either downgrade CWA for Windows 2511 to a previous version like 2508.10, or turn off "Previous version of Microsoft IME" option in the impacted client machine under GUI "Settings > Time & Language > Language & Region > Korean > Language Option > 'Microsoft IME' Keyboard Options > Compatibility".

Issue/Introduction

The article describes a keyboard/IME compatibility issue between CWA for Windows 2511 and Microsoft "Previous version of Microsoft IME" feature.